Frequent Questions : What are the browser requirements for using ChangeDetect?

 

 

What are the browser requirements for using ChangeDetect?

ChangeDetect has been tested with Microsoft Internet Explorer 4+ and Mozilla Firefox 4+.

ChangeDetect requires both JavaScript and cookies. If your browser is not accepting cookies, you will need to enable your browser's cookies. You might also try adding ChangeDetect as a trusted site.

While ChangeDetect has been tested with standards compliant browsers, you may need to upgrade to a current browser version with the proper settings enabled to avoid any potential registration or login issues.

You may also want to confirm that your computer's system date and time are current.

Be sure to contact us with any registration or login issues. Note: Any sophisticated use of a proxy, firewall or other anonymizing software is outside the scope of ChangeDetect end-user support.

Signup Now FREE

arrow left Back to Previous